MC909 fault help

Forum for MC, SP, TR series and other groove and drum machines

MC909 fault help

Postby neotechtonics » 07:39, 15 August 2012

Hi all.

Asking for assistance on behalf of a friend. He turned his MC909 on last night.. it powers up fine but no lights or controls working. It still receives MIDI and still generates sounds (got start signal from Electribe MX-1) I think he said the screen is still working. So i'm thinking it's a problem with the control surface not getting power. I'm hoping it's just a loose connection somewhere. I'll be checking on the forum for a walk thru on opening the beast up so I can know what to expect inside and how to logically get her open... or even better find a thread where someone has fixed the same problem before. Haven't had a chance to look at it myself to do further troubleshooting but I'll go have a look at it tonight to isolate whats working and what isn't to try narrow down the problem.

Is there a ribbon cable connecting the control circuitry to the main board that could've worked loose? or some kind of power cable to the control cirtuitry?
He played a gig with it 6 days ago and all was working perfectly fine then.

PS: i'm really surprised that the MC808 gets a dedicated link on the main page of this forum and the MC909 is relegated to the back rooms :P
neotechtonics
 
Posts: 4
Joined: 07:22, 15 August 2012


Re: MC909 fault help

Postby neotechtonics » 12:46, 7 September 2012

thanks for all the replies.. it might take me a while to go thru and thank all of you individually for your assistance. bear with me. -facepalm-
neotechtonics
 
Posts: 4
Joined: 07:22, 15 August 2012

Re: MC909 fault help

Postby ZipSnipe » 22:38, 15 March 2017

4 years late but yeah it is possible that a cable is loose also alot of buttons tie into each other, in other words if one button goes bad it takes out a several other buttons with it, this is not all buttons but some do tie together. I know when I got my broken MC909 it was the pads were bad and like 3 buttons needed to be replaced and no sounds would come out until I used the d beam then I realized it was still alive and fixed everything else.
ZipSnipe
 
Posts: 32
Joined: 15:10, 21 January 2014


Return to Grooveboxes

Who is online

Users browsing this forum: No registered users and 1 guest