How to avoid phasing while controlling V-Synth XT from DAW?

Forum for V-Synth, V-Synth XT, V-Synth GT and V-cards

How to avoid phasing while controlling V-Synth XT from DAW?

Postby dysamoria » 09:06, 26 August 2017

i'm using Logic's "External Instrument" plugin to integrate several external synthesizers into my DAW setup. This works fine with everything but my V-Synth XT. With the V-Synth XT, i get phasing, from what i assume is a MIDI loop. Any notes sent via Logic or my master keyboard results in phasing. The "Preview" button on the V-Synth XT itself is the only way i can hear the V-Synth XT without phasing. Recording in Logic shows only ONE note, so i don't know where the MIDI problem is.

Even if i create separate "External MIDI" and Audio tracks, instead of using the "External Instrument" plugin, the same problem occurs. For example: i created an audio track that's taking input from the V-Synth XT and created an External MIDI track sending to the V-Synth XT's MIDI port. There's phasing.

Strangely, it does not happen when the "External MIDI" track is sent to the port for V-Synth XT's USB connection. i don't want to use the USB connection because the drivers don't work with newer Mac OS versions and i'm expecting to upgrade from Snow Leopard at some point. Also, i've seen constant issues with the USB MIDI connection and want to avoid those.

"Local SW" does not fix the problem (it disables the audio engine, unlike the similarly named setting on every other keyboard synth out there).

In the past, i've just tolerated it, but i'm sick of hearing the phasing. What is wrong with this setup??
dysamoria
 
Posts: 42
Joined: 23:54, 17 April 2006
Location: Coplay, PA, unfortunately


Re: How to avoid phasing while controlling V-Synth XT from D

Postby dysamoria » 12:16, 27 August 2017

Found my problem. In case anyone needs to know: My Logic environment setup for my V-Synth XT included a filter for CC16 and CC17 (i can't remember why) and all the MIDI was being sent from the filters and MIDI monitor into another instrument mapped to the same MIDI port again. i don't know why it was set up this way. i turned off that last instrument object in the chain and things sound correct. No more doubled notes.
dysamoria
 
Posts: 42
Joined: 23:54, 17 April 2006
Location: Coplay, PA, unfortunately


Return to V-Synth

Who is online

Users browsing this forum: No registered users and 1 guest