Bloody TR-8 latency!!! Please help.

Forum for Apple Mac computers

Bloody TR-8 latency!!! Please help.

Postby Kid Blast » 09:41, 9 May 2015

I am running Ableton Live 9 on a Macbook Pro with OS X 10.9.5, 2.8GHz and 16GB ram.

I have a Roland TR-8 which I bought about a month ago, and I’m running it through a powered USB hub into the computer.

When I run the TR-8 as a USB audio interface, the latency is almost half a beat. I would love to run it over USB but it is just a total waste of time, as the latency makes it unusable.

When I run the TR-8 via midi with the audio outputs going into my MOTU Ultralite, and input it through the External Device Rack, there is latency of 1/256th of a second, which in some cases gives a nice swing to tracks, but in other cases throws the groove of a track right out.

I understand I can program the TR-8 and then record each part in and warp to suit the song, but that is not going to happen, as I like a fast workflow. It is really annoying, because I want to be able to incorporate the TR-8 into my songs in realtime, alongside other drum sounds from Maschine , so they are all playing in time at the same time. I have played with the latency compensation on the External Device Rack but it doesn’t change anything.

Is there some really simple thing that I am overlooking to make this work? I have looked at forums all over the internet, and watched every Youtube video I can find on the TR-8, but I’m getting nowhere.

Please help or I’m just going to get rid of the bloody thing, which I really don’t want to do.

Thanks.

PS – I have also tried using it as an aggregate audio device in OSX, but that didn’t work either.
Kid Blast
 
Posts: 2
Joined: 09:32, 9 May 2015


Re: Bloody TR-8 latency!!! Please help.

Postby PauloF » 00:23, 4 August 2015

Welcome to the Clan!

Did you try connecting the TR-8 directly to one of your MBP's USB Ports? does the AUDIO interface behaves the same way when connected directly and not via the USB Hub?
User avatar
PauloF
 
Posts: 4079
Joined: 02:35, 16 January 2006
Location: Lisbon, Portugal


Return to Mac

Who is online

Users browsing this forum: No registered users and 1 guest