Windows 10: How I got Fantom X USB Drivers to work...

Forum for Fantom-S/S88, Fantom-X6/7/8, Fantom-XR and Fantom-Xa

Windows 10: How I got Fantom X USB Drivers to work...

Postby Credo » 08:45, 3 October 2015

First I found the Windows 8 version here: http://roland.com/support/article/?q=do ... d=62483063

I tried to install it but it did not work.

Next I ran through this process that tells Windows that it can install unsigned drivers.
http://en.code-bude.net/2015/08/19/how- ... indows-10/

In my Fantom X driver archive I found and edited the RDIF1045.inf file

Change [Roland.NTamd64.6.2] so it looks like this:

[Roland.NTamd64.6.2]
;; Windows10
%RDID0045DeviceDesc%=RDID0045Install, USB\VID_0582&PID_006D ; FANTOM-X

(essentially, I just changed the Windows8 to Windows10 and left the rest of the file alone)

Don't run the installer again...instead do it manually...........

Next I plugged in the Fantom to the USB port, opened the Device Manager, and manually installed the driver by pointing it to the directory holding all the Fantom X driver files.
1. Plug in your Fantom via USB.
2. Right click the start button and choose device manager.
3. Locate your Fantom X, it should show up in the unidentified ? section of devices.
4. Right click it and choose update driver.
5. Browse your disk(s) and find the directory holding your Fantom X drivers.

Hopefully it will find everything it needs and install itself for you.

So far it seems to be working for me, at least the MIDI over USB part..as I haven't tried accessing the memory or flash card yet.

I'll come back and follow up with more posts once I get a chance to try the memory/flash mounting side of things.
Credo
 
Posts: 59
Joined: 10:38, 29 January 2015


Re: Windows 10: How I got Fantom X USB Drivers to work...

Postby Alazarin » 23:34, 8 October 2015

I got the warning panel about unsigned drivers or whatnot. All I had to do was to click on the 'go ahead anyway' option and it installed the drivers. Bliss!
User avatar
Alazarin
 
Posts: 25
Joined: 12:50, 26 May 2007

Re: Windows 10: How I got Fantom X USB Drivers to work...

Postby mpcrabtree » 18:44, 19 October 2015

I assume this won't work if you don't do the "unsigned drivers " piece. Without it, I still get that the drivers are not for an x64 system. Trying to get my Fantom XR up and running under W10.
mpcrabtree
 
Posts: 5
Joined: 14:04, 28 September 2015

Re: Windows 10: How I got Fantom X USB Drivers to work...

Postby mpcrabtree » 22:02, 19 October 2015

OK. I ran through the full instructions,. including the unsigned rivers changes, but I still get the same error message:
The folder you specified doesn't contain a compatible software driver for your device.......

Any ideas what else is missing?
mpcrabtree
 
Posts: 5
Joined: 14:04, 28 September 2015

Re: Windows 10: How I got Fantom X USB Drivers to work...

Postby Credo » 04:50, 20 October 2015

Maybe I just got lucky....
This was a fresh install of Windows 10, 64bit version...

The Fantom X does have to be plugged in and powered on so it'll show up in the device list. Make sure it's in MIDI mode...not storage or flash card mode.

Do make sure you're pointing it to the directory with your RDIF1045.inf file once you tell device manager you'd like to choose the drivers it will install.

Give it a try without an edited RDIF104.inf file first.
If that doesn't work go through it with a text editor and try different entries...

It did take me a number of tries. I'd tried using the installer first and that just flat out refused to work. You might try running the installer, and when it asks to uninstall, ignore that and then go through the process of trying to install it using the device manager.

I remember tinkering with the RDIF1045.inf and adding different entries:

[Roland.NTamd64.6.1]
;; Windows7
%RDID0045DeviceDesc%=RDID0045Install, USB\VID_0582&PID_006D ; FANTOM-X

[Roland.NTamd64.6.2]
;; Windows8
%RDID0045DeviceDesc%=RDID0045Install, USB\VID_0582&PID_006D ; FANTOM-X

[Roland.NTamd64.6.3]
;; Windows8.1
%RDID0045DeviceDesc%=RDID0045Install, USB\VID_0582&PID_006D ; FANTOM-X

[Roland.NTamd64.6.4]
;; Windows10
%RDID0045DeviceDesc%=RDID0045Install, USB\VID_0582&PID_006D ; FANTOM-X

etc.....
Eventually it accepted it and installed through the Windows device manager.

It took me several tries, and I did try running that installer several times. I wish I knew the exact magic bullet that got it working...I just know that when it did finally take, I was installing through the device manager after having entered the mode that allows installing unsigned drivers.

Image
Credo
 
Posts: 59
Joined: 10:38, 29 January 2015

Re: Windows 10: How I got Fantom X USB Drivers to work...

Postby mpcrabtree » 06:38, 20 October 2015

Thanks for the response. I did try several times, with and without uninstalling using the Roland utility and with various iterations of the file and yes , the Fantom was powered up in MIDI mode so it showed as a device with no working driver and yes, I pointed to the correct(edited) version of the .inf file.

Everything was as you said and including the instructions for allowing unsigned drivers, it just didn't work for me today. Maybe when I give it another go ..... I'll keep all up to date if it works, but hopefully Roland will do the necessary quick work to get this working as it should.
mpcrabtree
 
Posts: 5
Joined: 14:04, 28 September 2015

Re: Windows 10: How I got Fantom X USB Drivers to work...

Postby Credo » 16:43, 20 October 2015

mpcrabtree wrote:hopefully Roland will do the necessary quick work to get this working as it should.


I wouldn't hold my breath. They never did one for Windows 8.1 that I know of. I used a similar hack to above, but the installer worked on Windows 8.1

You might try going through the 'Browse from my computer...>Let me pick from a list...>have disk' dialogue to see if it takes that way.

In the meanwhile, I'm studying up on how to dig into my Windows installation with notes from true Windows GuRus and see exactly what inf file it did accept, and where it stashed all the relevant driver files. I'll come back and follow up if I discover anything useful.

If all else fails, grab a DIN MIDI interface for the PC if you do not already have one. The Fantom X Editors/Librarians will still work through the old DIN cable. You should be able to find them for less than $10.........just be sure to confirm it'll work with Windows 10, AND has an easy exchange/return policy.

From what I can tell so far, the USB storage mode works with bog standard Microsoft Drivers, so that side of the Fantom should still work OK. It's working here and doesn't show any Roland Branded drivers for the storage side.
Credo
 
Posts: 59
Joined: 10:38, 29 January 2015

Re: Windows 10: How I got Fantom X USB Drivers to work...

Postby Credo » 17:38, 20 October 2015

OK, I took a closer look and here is everything in the dirverstore that Windows eventually accepted here.
rdif1045.inf_amd64_99fd7609b1056ea0.zip
(301.29 KiB) Downloaded 762 times


Note, this is on a Windows 10 64bit installation...

In the archive above, you can see the exact rdif1045.inf file that Windows finally took for me.

Boot into the mode that allows unsigned drivers to be installed.

Unzip the package above and try installing the drivers from there with the "Windows Device Manager".

Here is my site of reference: http://superuser.com/questions/262012/h ... stallation
Credo
 
Posts: 59
Joined: 10:38, 29 January 2015

Re: Windows 10: How I got Fantom X USB Drivers to work...

Postby mpcrabtree » 17:16, 21 October 2015

Got it working.

What worked for me is as follows:-

1) download the Roland Fantom X driver for USB on Windows 8 and unzip it. "Roland"
2) download Credos .zip file above into a different directory. "credo"
3) Took just the RDIF1045.inf file from credos download and placed it in the "Roland" directory.
4) ran the sequence to allow unsigned drivers per Credos first post in this topic.
5) plugged in the Fantom XR into USB and powered on the device and ensured that the System Menu showed MIDI communication and not STORAGE.
6) opened up Device Manager, note that Fantom X shows as a device that is not working right click on the device and click on Update drivers.
7) I picked the directory to choose for the driver installation. "Roland" but with credos adapted RDIF1045.inf file in it.
8) It finds a driver for FANTOM X and use this to install, it will complain about unsigned drivers or some such message, but just push through, then driver install will occur.
9) Reboot.

Thanks to credo for quick responses and the helpful guides that got me there.

Now I have to see if this gets me through the Presonus Firewire issues with W10 so I can connect to my Roland VS2400CD ..... what fun upgrades are?.... Luckily I have workarounds for that using other equipment, so not as critical as this Roland Fantom-XR issue was.

Thanks again Credo.
mpcrabtree
 
Posts: 5
Joined: 14:04, 28 September 2015

Re: Windows 10: How I got Fantom X USB Drivers to work...

Postby mpcrabtree » 13:49, 22 October 2015

An Update:

Whilst I managed to get the FANTOM X driver installed and it shows up in both the Roland editors and inside Cubase, my issue is that now when I send anything from Cubase through that driver, it crashes Cubase (consistently).

I decided to uninstall the FANTOM X USB driver and have gone back to using good old fashioned (but slow) MIDI cables.
mpcrabtree
 
Posts: 5
Joined: 14:04, 28 September 2015

Re: Windows 10: How I got Fantom X USB Drivers to work...

Postby Credo » 19:34, 22 October 2015

mpcrabtree wrote:An Update:

Whilst I managed to get the FANTOM X driver installed and it shows up in both the Roland editors and inside Cubase, my issue is that now when I send anything from Cubase through that driver, it crashes Cubase (consistently).

I decided to uninstall the FANTOM X USB driver and have gone back to using good old fashioned (but slow) MIDI cables.


Interesting...

Make sure Windows 10 is updated, as there have been a number of hot-fixes from Microsoft for things MIDI and Audio. While the PC has internet access, click the start bar and type "Check for updates"...open that and scan for any KBhotfixes you might have missed.

You might also want to try using the Fantom X CPL widget to try the "Light In" setting.
To access this you can find it in the Windows Control panel, or click the start bar and type in Fantom-X, then launch the listing under 'settings'.

(below is slightly off topic unless you Also use Cubase)

What version of Cubase?
Here it's good with the Fantom X Editor, Sibelius 7.5.1, MUSE Score via 'JACK', several apps over Atari ST Emulation, Bidule, and Cubase 8.0.30 Pro.

At what point does it crash? Do you get an error message of any kind?

Here are my Cubase Synth Profiles if you'd like to try them. They should work through the Fantom X MIDI driver, or over another interface if you have to go that route. I made them with Cubase 7.5, but they work just fine with 8 Pro as well.

To import them you'd do it through the "Devices>MIDI Device Manager" menu.

These are for an XR, but they should be pretty close for any Fantom X derivative. The bank formats are certainly valid for all the X series...just rename any patches if that is required:
FullSetUp-10-3-2015.xml
(4.73 MiB) Downloaded 159 times


I use a separate profile for each SRX card that's in my XR Unit.

I also have built what I call a 'mode' profile which, when a track is set to channel 10, allows me to choose a 'performance patch', and easily automate punching between 'performance or patch mode' and punching in and out of GM or GM2 mode via the device panel.

I've also modified the GM2 subset a bit so it will call up the proper patch even if the Fantom is NOT in GM or GM2 mode.

As for how I set it up in Cubase:
I assign each pair of the Fantom's audio outputs as an 'external instrument' in the "VST Connections" tab (tap F4 to get at this), but I do not assign them to a specific MIDI device. If you prefer you can set them up as MONO channels. Note: I do NOT assign a MIDI port here because I use multiple synth profiles for the same XR Unit. Also note, if you prefer, you can build all of the Fantom audio outputs into the same VST Connection...for me it's just simpler to treat each stereo pair as a separate instrument on the mixing console since I don't always have everything hooked up in a four or six output fashion.

Image

Once I've set them up, I can assign them as 'rack instruments' in the Instrument Rack (so their audio inputs show up on the Mixing Console). From there, all I need do is create MIDI tracks and choose the Fantom profile I want it to use (or bypass a profile and choose the RAW Fantom X MIDI output if I want to manually punch in bank and program info), and set the proper MIDI channel and patch I want. My general layout for the Fantom looks something like this:
Image
Credo
 
Posts: 59
Joined: 10:38, 29 January 2015

Re: Windows 10: How I got Fantom X USB Drivers to work...

Postby jef_citron1 » 13:15, 10 January 2016

Thank you very very very much
Thanks to you I can use my new Fantom XR with Windows 10
It's marvellous !!!

Good luck Credo and mpcrabtree
jef_citron1
 
Posts: 1
Joined: 10:13, 10 January 2016

Re: Windows 10: How I got Fantom X USB Drivers to work...

Postby Harvickfan4 » 01:40, 28 January 2016

I can't get this to work. I get a Windows message that says it encountered a problem installing the driver software for your device. It says it found the driver but it encountered an error while attempting to install it and says the Hash for the file is not present in the specified catalog file and that it is likely corrupt or the victim of tampering.
Harvickfan4
 
Posts: 6
Joined: 17:47, 2 November 2015

Re: Windows 10: How I got Fantom X USB Drivers to work...

Postby jackddavis » 08:54, 21 February 2016

You guys are awesome! Driver installed successfully. Great work. @Harvickfan4, just in case you never got it working, you're getting that error because you need to follow the above discussion around restarting in Advanced mode (Allow Unsigned Drivers) before trying to install the driver in DevMgmt.
jackddavis
 
Posts: 1
Joined: 08:46, 21 February 2016

Re: Windows 10: How I got Fantom X USB Drivers to work...

Postby Alazarin » 03:27, 11 March 2016

I'm back again as I'm building up a new computer with Windows 10. This time when I tried following the method outlined above it kept failing until I disabled driver signing using the method outlined on this page: http://www.howtogeek.com/167723/how-to-disable-driver-signature-verification-on-64-bit-windows-8.1-so-that-you-can-install-unsigned-drivers/

I had spent hours tinkering around with the inf file as well as using the 'disable driver signing' batch file to no avail. As soon as I disabled driver signing as described on the 'How-to Geek' site it installed first time. I would strongly recommend this as a workaround for anyone who is desperate for a way to get their unsupported Roland gear to work with Windows 10.
User avatar
Alazarin
 
Posts: 25
Joined: 12:50, 26 May 2007

Next

Return to Fantom-S and Fantom-X

Who is online

Users browsing this forum: No registered users and 2 guests