Turning off PCM sound generator?

Forum for SH-01 GAIA

Turning off PCM sound generator?

Postby vxfan » 19:07, 25 July 2010

Hey,
I am trying to integrate the Gaia into my midi setup but cannot figure out if you can turn off the PCM sound module so the sequencer does not trigger the PCM sounds on those channels that my other synths use. I have not seen it in the manual yet. Any ideas?
Thanks!
vxfan
 
Posts: 42
Joined: 00:49, 18 December 2009
Location: USA


Re: Turning off PCM sound generator?

Postby RonF » 07:11, 2 August 2010

I'm having the exact same question/problem. Is there a solution? Surely there must be a way to defeat the PCM sounds on channels you do not wish to use them for?????????
RonF
 
Posts: 180
Joined: 17:48, 10 February 2010
Location: San Diego, CA USA

Re: Turning off PCM sound generator?

Postby JunoJohn » 00:19, 12 August 2010

I don't have the Gaia, but I checked out the MIDI implementation (to download click here). This is from page 3.

To set "GM System Off," send the following MIDI System Exclusive Message:

F0 7E 7F 09 02 F7

Hope this is what you were looking for.
JunoJohn
 
Posts: 792
Joined: 08:29, 24 February 2008
Location: Washington DC

Re: Turning off PCM sound generator?

Postby vxfan » 04:16, 14 August 2010

Thanks,
I was hoping there was a shift function via the Gaia's panel.
vxfan
 
Posts: 42
Joined: 00:49, 18 December 2009
Location: USA

Re: Turning off PCM sound generator?

Postby skuppy » 10:58, 15 August 2010

Hey guys

I didnt have successl executing this sysex message
has anyone else been able to disable the GM sounds using this sysex msg?

I just used midi-ox with the SH-01 as output and used the command window to send the sysex msg.......did I miss something ?

thanks
skuppy
 
Posts: 47
Joined: 11:48, 28 October 2008
Location: Australia

Re: Turning off PCM sound generator?

Postby JunoJohn » 22:29, 15 August 2010

According to the MIDI Implementation Chart (page 61 of the Owner's Manual), reception of System Exclusive Messages can be turned on or off. Maybe they are turned off by default?

As a test, you could send a different System Exclusive Message. However, I don't see anything in the manual telling you how to turn System Exclusive on/off, so testing might be pointless.

Perhaps one of you guys with a Gaia should call Roland tech support, and share the response from them.
JunoJohn
 
Posts: 792
Joined: 08:29, 24 February 2008
Location: Washington DC

Re: Turning off PCM sound generator?

Postby skuppy » 01:06, 16 August 2010

yea you might be right Junojohn
let me have a muck around with this one
skuppy
 
Posts: 47
Joined: 11:48, 28 October 2008
Location: Australia

Re: Turning off PCM sound generator?

Postby mchacotay » 07:57, 1 October 2010

I also tried turning off GM sounds with the REMOTE KEYBOARD = off and also the SysEx message JunoJohn posted (I even double checked with the midi implementation chart :)). Those crappy sounds are still pouring out. Have anyone been successful at this?
mchacotay
 
Posts: 1
Joined: 07:52, 1 October 2010

Re: Turning off PCM sound generator?

Postby Frank6502 » 09:28, 4 October 2010

try send string + cheksum

without checksum roland doesnt acept sysex.
Frank6502
 
Posts: 4
Joined: 13:02, 18 February 2007

Re: Turning off PCM sound generator?

Postby excalibas » 03:37, 24 March 2011

I have the same problem and it is very strange because if I send a Roland Exclusive message like this:

F0 41 10 00 00 41 12 10 00 01 00 06 69 F7

I successfully set the OSC Wave of Temporary Patch to SUPER-SAW like the example on page 20 of the MIDI implementation.

With Universal Realtime System Exclusive Messages it also works, I can change the master volume with:

F0H 7FH, 7FH, 04H, 01H, llH, mmH F7H (page 4)

But the Universal Non-realtime System Exclusive Messages don't work for me.

I lost a hole day with this and it is specially frustration because it didn't work.

Anyone had success turning that dam piano sound off?
excalibas
 
Posts: 4
Joined: 03:21, 24 March 2011

Re: Turning off PCM sound generator?

Postby Grauw » 08:46, 24 March 2011

You can’t turn it off. All the ‘GM System Off’ messages do is a MIDI reset of the channel settings. Play a note and then send it, you’ll hear it gets stopped.

From what I understand these GM system messages are sent at the beginning of MIDI files to ensure all settings are on their defaults.
Grauw
 
Posts: 46
Joined: 04:29, 8 December 2010

Re: Turning off PCM sound generator?

Postby excalibas » 12:41, 31 March 2011

So is not possible to turn them off?

This makes the Gaia useless in any midi chain :|

I wonder what went thru Roland peoples minds when they did this, I just bought mine to play live and I have lots of problems because of this.

Anyways thanks for the explanation Grauw at least I know its not something I am doing wrong.
excalibas
 
Posts: 4
Joined: 03:21, 24 March 2011

Re: Turning off PCM sound generator?

Postby Grauw » 03:19, 3 April 2011

You might consider this little device, or its bigger brother: http://www.midisolutions.com/prodevp.htm

It costs a bit but it should be able to filter out channels, reassign CC numbers, transform sysex messages to CC messages, etc.
Grauw
 
Posts: 46
Joined: 04:29, 8 December 2010

Re: Turning off PCM sound generator?

Postby Atlas5 » 05:45, 4 April 2011

What sequencer are you using? When I use my midi router/switcher everything works fine. Can you have a different MIDI cable configuration? What other keyboards are you using?

I don't even connect the SH-01 MIDI when playing live, as I simply play the thing.
Atlas5
 
Posts: 563
Joined: 17:59, 31 August 2008
Location: Oakland CA, USA

Re: Turning off PCM sound generator?

Postby vxfan » 00:10, 5 April 2011

The easiest solution when using the Gaia with a computer based DAW is to send a seperate USB cable to it and have it dedicated as its own MIDI interface. Not a big deal. Most of my newer synths are routed this way.
vxfan
 
Posts: 42
Joined: 00:49, 18 December 2009
Location: USA

Next

Return to SH-01

Who is online

Users browsing this forum: No registered users and 1 guest