Boutiques with MX-1 : Bad latency

Forum for Aira

Re: Boutiques with MX-1 : Bad latency

Postby Chug Norris » 10:41, 9 November 2017

Again Myrk - not 12ms, it's 15ms at least, and that's in the absolute optimal circumstances.

And how do you apply track delay with hardware sequencers, eg MPC Live? You can't really, trust me. Given that Roland market the MX-1 very much as a hands on, live performance tool, it stands to reason that many users will be using theirs without a DAW - as many user videos out there prove.

Whether Roland 'found it acceptable' or not, the fact is cheaper synths from other manufacturesrs AND EVEN OTHER ROALND ACB KIT like the TR-8 are nowhere near this problematic with lag. Now you can suggest, as you have done, that the 'fault' lies with the end user for a) being able to hear 15ms lag in the first place(!) or b) not investing in clunky third party hardware tools to lag everything else (ie all the acceptable equipment) by an equivalent amount, but personally I'll just stick to the view that Roland dropped a bit of a major bollock with these units, when they put processors in there which were too underpowered to deliver the algorithims quickly enough to get away with.

I find it endlessly fascinating that folk can't just accept that. I can only put it down to not wanting to feel cheated on their new pride and joy purchase, which is understandable I suppose. I on the other hand HAVE accepted it, but what I won't accept is the apologists for it - trying to justify that it's merely the problem of nitpicky folk like me, rather than Roland's fault. It is what it is, but stop the gaslighting please.
Chug Norris
 
Posts: 10
Joined: 12:53, 23 January 2017


Previous

Return to Aira

Who is online

Users browsing this forum: Alexa [Bot] and 3 guests